MRI Logo
REAL ESTATE SOFTWARE

PMX X.7 PAH Americas - Orion - Reported Incident - Resolved

Incident Report for MRI Software

Resolved

Dear MRI Client,
The remediation actions were completed on 07 Aug 2026 at 6:07 UTC, and the issue with PMX X.7 PAH Americas - Orion is now resolved.
We appreciate your patience while we addressed this incident.

Regards,

MRI Software

Posted Aug 06, 2026 - 18:41 UTC

Identified

Dear MRI Client,

We have identified the source of the issue affecting PMX Orion. Our technical team is actively working on a fix. We will continue to post updates on our progress until the issue is resolved.

Thank you for your patience while we address this.

Regards,

MRI Software

Posted Aug 06, 2026 - 17:48 UTC
This incident affected: Property Management X (PMX X.7 PAH Americas - Orion).