MRI Logo
REAL ESTATE SOFTWARE

PMX X.7 Americas - Triton - NA - Reported Incident - Investigation Underway

Incident Report for MRI Software

Identified

Dear MRI Client,

We have identified the source of the issue affecting PMX X.7 Americas - Triton. Our technical team is actively working on a fix. We will continue to post updates on our progress until the issue is resolved.

Thank you for your patience while we address this.

Regards,

MRI Software

Posted Feb 22, 2026 - 14:43 UTC

Investigating

Dear MRI Client,

We are aware of a potential issue which started on 22-Feb-2026 at 09:45 UTC affecting PMX X.7 Americas - Triton. Our team is currently investigating to identify the cause and restore normal service as quickly as possible.

Further updates will be posted here as more information becomes available. We appreciate your patience during this time and regret any inconvenience this may cause.

Regards,

MRI Software

Posted Feb 22, 2026 - 11:08 UTC
This incident affects: Property Management X (PMX X.7 Americas - Triton).