RentPayment Planned Maintenance Update 5/20/2023
Maintenance
2023-05-21T07:00:54.6700000Z
RentPayment Planned Maintenance Update 5/20/2023
Status: closed
Start:
2023-05-21T02:00:48.0000000Z
End:
2023-05-21T07:00:54.6700000Z
Duration: 5 hours
Affected Components:
Americas
RentPayment
Update
2023-05-21T02:00:48.0000000Z
2023-05-21T02:00:48.0000000Z
Dear MRI/RentPayment Client,
A Planned Maintenance Update (PMU) for RentPayment will be applied between Saturday, 20th, May, 2023 10pm EDT and Sunday, 21st, May, 2023 3am EDT. During this time, the RentPayment platform will be unavailable. If this update is delayed, additional information will be posted on the MRI Notifications page.
If you have any questions or concerns, please contact RentPayment Technical Account Management Support at accountmanagement@rentpayment.com
We appreciate your business and look forward to building success together.
MRI Software / RentPayment
Resolved
2023-05-21T07:00:54.6700000Z
2023-05-21T07:00:54.6700000Z
Dear MRI/RentPayment Client,
The Planned Maintenance Update has been completed.
If you have any questions or concerns, please contact RentPayment Technical Account Management Support at accountmanagement@rentpayment.com
MRI Software / RentPayment